Dash lights out - Jaguar Forums - Jaguar Enthusiasts Forum

Notices
XJS ( X27 ) 1975 - 1996 3.6 4.0 5.3 6.0

Dash lights out

 
  #1  
Old 03-05-2019, 09:02 PM
Junior Member
Thread Starter
Join Date: Mar 2018
Location: Florida
Posts: 9
Thanked 1 Time in 1 Post
Angry Dash lights out

Hey guys, I recently had an issue with the radio on my 83 XJS, I replaced the radio but ever since my dash lights when out.... they were working perfectly fine until then. I pulled the cover under the dash and all seems to be in the right order. Are there any dash light related cables behind the radio I am not aware of? This is my first XJS love it but the dark dash is kicking my OCD into high gear. Please help!!!
 
  #2  
Old 03-06-2019, 01:21 AM
Veteran Member
Join Date: Jan 2012
Location: France
Posts: 8,805
Thanked 4,331 Times in 2,769 Posts
Default

Look at the fuse, it is easy to short it when swapping a radio.
 
  #3  
Old 03-06-2019, 05:10 AM
rgp
rgp is offline
Veteran Member
Join Date: May 2010
Location: warwick
Posts: 1,061
Thanked 185 Times in 150 Posts
Default

you haven't inadvertently moved the position of the pointless rheostat switch under the knee bolster
 
  #4  
Old 03-06-2019, 04:19 PM
Senior Member
Join Date: Dec 2017
Location: Brookfield CT
Posts: 306
Thanked 42 Times in 38 Posts
Default

When you say "dash Lights' , do you mean instrument panel lights(speedometer etc) or other dash lights. Aren't the other non instr panel lights fiber optic where one bulb lights all?
 
  #5  
Old 03-06-2019, 11:03 PM
Junior Member
Thread Starter
Join Date: Mar 2018
Location: Florida
Posts: 9
Thanked 1 Time in 1 Post
Default

It actually worked on mine but no, I did not move it
 
  #6  
Old 03-06-2019, 11:04 PM
Junior Member
Thread Starter
Join Date: Mar 2018
Location: Florida
Posts: 9
Thanked 1 Time in 1 Post
Default

all the instrument panel and center console all dark
 
  #7  
Old 03-06-2019, 11:06 PM
Junior Member
Thread Starter
Join Date: Mar 2018
Location: Florida
Posts: 9
Thanked 1 Time in 1 Post
Default

check the fuse, all good with the fuse
 
  #8  
Old 03-08-2019, 02:00 AM
orangeblossom's Avatar
Veteran Member
Join Date: Feb 2013
Location: uk
Posts: 15,407
Thanked 2,029 Times in 1,571 Posts
Default

Hi Frank

Maybe you forgot to connect an Earth Wire?

Which could be why your Fuse is OK although the lights don't come on


 
  #9  
Old 03-09-2019, 04:05 PM
warrjon's Avatar
Veteran Member
Join Date: May 2010
Location: Vic Australia
Posts: 4,389
Thanked 2,357 Times in 1,593 Posts
Default

There are 5 wires 3 RW (Red White) and 2 RU (Red Blue). One of the RU is feed and the other goes to the trip computer. DO you have trip computer lights?

You could bypass the rheostat by connecting the RU directly to RW, this will verify that the rheostat is good/bad.

If you still have no lights use a DMM and verify you have 12V on the feed RU wire.
 
  #10  
Old 03-14-2019, 11:24 AM
rgp
rgp is offline
Veteran Member
Join Date: May 2010
Location: warwick
Posts: 1,061
Thanked 185 Times in 150 Posts
Default

Have you got them back?
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
annamiata
XJ XJ6 / XJR6 ( X300 )
2
01-17-2019 01:10 PM
charger12
X-Type ( X400 )
3
04-04-2012 04:23 PM
robhair
XJ40 ( XJ81 )
6
12-08-2011 05:27 AM
85_305
X-Type ( X400 )
7
12-29-2009 04:37 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Dash lights out


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: