XK / XKR ( X150 ) 2006 - 2014

Help-New Battery Installation

 
  #1  
Old 04-18-2019, 05:48 AM
Senior Member
Thread Starter
Join Date: May 2012
Location: PA
Posts: 124
Received 9 Likes on 8 Posts
Default Help-New Battery Installation

I'm installing my new battery this morning and as soon as I put the cable on the posts the alarm starts going off. What am I missing???

Thanks!
 
  #2  
Old 04-18-2019, 05:53 AM
Veteran Member
Join Date: May 2009
Location: Yorkshire, England
Posts: 23,192
Received 3,418 Likes on 3,029 Posts
Default

Nothing. Just turn it off with fob or key in ignition.
 
  #3  
Old 04-18-2019, 05:56 AM
Senior Member
Thread Starter
Join Date: May 2012
Location: PA
Posts: 124
Received 9 Likes on 8 Posts
Default

Bingo... thank you!!
 
  #4  
Old 04-18-2019, 07:23 AM
GGG's Avatar
GGG
GGG is online now
Join Date: Dec 2011
Location: Durham, UK
Posts: 108,631
Received 10,170 Likes on 8,373 Posts
Default

Originally Posted by Kongo1 View Post
..... What am I missing???
VEHICLE DETAILS

Your forum profile only shows 1996 VdP but you have posted in X150 forum. Additional vehicle, replacement vehicle or wrong forum?

Graham
 
  #5  
Old 04-18-2019, 07:32 AM
Senior Member
Thread Starter
Join Date: May 2012
Location: PA
Posts: 124
Received 9 Likes on 8 Posts
Default

So I bought the car almost 2 months ago and am absolutely in love with it. I actually look forward to going to work on the days that I take it.
It's a 1 owner 2008 XK that had 35K miles.

- the glove box broke about the 3rd time I opened it and I fixed it using the cotter pin method thanks to this forum.

-the head unit would freeze every once in a blue moon and I read on here that it was a symptom of the battery. I purchased a ctek 4.3 and I plugged it in every time I parked it. Even though the car would fire right up I noticed it would take a bit for the head unit to go from the leaper screen to the home screen. I ran the "recond" mode on the ctek and the first time I started it up the home screen popped up immediately and I thought great, however, it went back to a slow response on the next start up even though it was always on the ctek.
So. to make a long story longer... I just bit the bullet and purchased a new battery (Interstate MTP-49/H8). I went with the same wet battery that was in there since it will be on the ctek. The home screen now pops up immediately upon start up every time so I'm assuming the battery was on it's way out.
Here's the question, this is not a cheap battery at $230 with a core. What I discovered when I took the old one out is that the sticker on it says 2/18 (but the code on the battery indicates mfg date of 7/17) so I'm assuming the PO didn't use a maintainer because looking at the carfax she only put a couple hundred miles on the car since the battery purchase (2/8).
Should this battery be on it's way out and not salvageable after this much time? I purchased the new one at an interstate distributor/warehouse, do you think it's worth asking if they would prorate the price when returning the old one?
 
  #6  
Old 04-18-2019, 08:07 AM
110reef's Avatar
Senior Member
Join Date: May 2017
Location: Baton Rouge, LA
Posts: 642
Received 183 Likes on 132 Posts
Default

I also have a 2008 XK low mileage car, bought 2 years ago with 23K miles on it, and have the occasional head unit issues. I also changed the battery (which was probably perfectly fine). After changing the battery, I still have the occasional head unit issues. I find that if I hold the start button down longer, I seem to have fewer head unit issues. Also, when the head unit does not boot up, restarting the car often helps, making me think it is not a battery issue, since starting again would in theory have drained the battery a little more from the first time I started the car. I just write it off to one of those quirks of this wonderful car.

I also had the glove box fail shortly after purchasing my car, and also easily fixed it thanks to advice on this forum. I also had the back window begin to separate, and used the Rhino glue and clamps to fix it. It is holding well so far. Otherwise, I have changed the brakes and the oil in my first 36K miles of ownership. And had repairs to the car after I was rear-ended. My car should pass 60,000 miles this week.
 

Last edited by 110reef; 04-18-2019 at 08:43 AM.
  #7  
Old 04-18-2019, 08:21 AM
Senior Member
Thread Starter
Join Date: May 2012
Location: PA
Posts: 124
Received 9 Likes on 8 Posts
Default

Thank you, that's my fear that the old battery is not actually bad and that it's just a little quirk with the head unit. However, when I restart immediately after it doesn't come on it stays Frozen but if I wait a little bit it does come back on. It also didn't pop up as fast as it does with the new battery so I guess we'll see if it lasts.
 
  #8  
Old 04-18-2019, 11:35 AM
Veteran Member
Join Date: Feb 2011
Location: Victoria, Canada
Posts: 1,677
Received 694 Likes on 509 Posts
Default

All of the symptoms above are signs of a battery not fully charged, whether new or not. Unless the CTEK unit indicates that the battery is fully charged, it is NOT, and you will get random electronic "issues" , touch screen performance being one of the most common, but only one of them. It can be random warning lights, windows, door locks, seats, touch screen, convertible top not functioning properly or any number of other symptoms.

A new battery not fully charged on installation, short runs, infrequent use...all guarantee sub-optimal battery voltage and that guarantees those warning signs.

We seem to have to state this on a daily basis (this is the second time today for me).
 
  #9  
Old 04-18-2019, 12:44 PM
Senior Member
Thread Starter
Join Date: May 2012
Location: PA
Posts: 124
Received 9 Likes on 8 Posts
Default

My 4.3 ctek would indicate fully charged after about 2 hours. Does this necessarily mean that the battery was good. When I would start the car it would take about 10 seconds for the screen to go from the leaper to the home screen. I charged my new battery at 10 amps for 3 hours before I installed it this morning and as soon as I fired it up the home screen was on.
 
  #10  
Old 04-18-2019, 01:35 PM
jagtoes's Avatar
Veteran Member
Join Date: Sep 2013
Location: NY
Posts: 4,647
Received 1,293 Likes on 977 Posts
Default

I just had my 5 year old battery replaced by the dealer 2 weeks ago. I had them check my old battery and it tested at 75% max capacity and could not be charged any further. The also tested the new battery before installation and it was at 100% capacity. I was only seeing a brightness difference on my screen but other then that no other problems. Dull screen is gone now. Also dealer reset the BMS as well as the service required note after the oil change. I also use a Ctek after every ride.
 
  #11  
Old 04-18-2019, 02:06 PM
Senior Member
Thread Starter
Join Date: May 2012
Location: PA
Posts: 124
Received 9 Likes on 8 Posts
Default

Thanks, that sounds like it could be a similar situation. Even though this battery is newer it might not have been kept on a maintainer while not being used over the last couple years.
 
  #12  
Old 04-18-2019, 07:48 PM
kj07xk's Avatar
Veteran Member
Join Date: Jan 2015
Location: Naperville, Illinois USA
Posts: 3,152
Received 772 Likes on 627 Posts
Default

Originally Posted by Kongo1 View Post
Thanks, that sounds like it could be a similar situation. Even though this battery is newer it might not have been kept on a maintainer while not being used over the last couple years.
And, if it was allowed to go flat, it will probably be ruined forever. (The battery, not the car!)
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Stuart S
XJ ( X351 )
10
12-16-2018 08:53 AM
richzak
XK / XKR ( X150 )
326
01-19-2018 07:03 AM
BryanL
XK / XKR ( X150 )
5
04-03-2017 08:56 AM
hatajay
XJ XJ6 / XJR6 ( X300 )
11
03-30-2010 05:56 PM
ccajun4real
S-Type / S type R Supercharged V8 ( X200 )
3
08-02-2008 06:14 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Help-New Battery Installation


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: