Ignition problem - Jaguar Forums - Jaguar Enthusiasts Forum

Notices
XK8 / XKR ( X100 ) 1996 - 2006

Ignition problem

 
  #1  
Old 03-13-2019, 07:55 PM
Senior Member
Thread Starter
Join Date: Feb 2015
Location: pleasanton ca
Posts: 101
Thanked 6 Times in 6 Posts
Angry Ignition problem

Having an intermittent starting problem. Car will start fine one day and when i turn the key nothing no lights on dash completely dead, after several attempts every thing lights up and car starts. Key turns fine no sticking.
 
  #2  
Old 03-13-2019, 08:17 PM
Veteran Member
Join Date: Dec 2010
Location: Douglasville Ga.
Posts: 7,507
Thanked 2,049 Times in 1,755 Posts
Default

It may be more than an ignition problem. Remove and clean the battery cables, both ends and the engine ground strap at the right rear of the engine- bell housing to frame.
 
The Following User Says Thank You to RJ237 For This Useful Post:
macs99 (03-13-2019)
  #3  
Old 03-13-2019, 08:33 PM
Senior Member
Thread Starter
Join Date: Feb 2015
Location: pleasanton ca
Posts: 101
Thanked 6 Times in 6 Posts
Default Ignition

Thanks i will try that first hope it turns out to be that simple.
 
  #4  
Old 03-14-2019, 05:54 AM
DavidYau's Avatar
Senior Member
Join Date: Jan 2019
Location: Bahrain
Posts: 182
Thanked 39 Times in 32 Posts
Default Location of Engine Earth Strap

I agree with RJ237's suggestion for checking earths. Have you checked the battery negative cable when you get a bad start - some have reported it gets hot.

For the Engine ground/earth strap - that's a PITA to reach. See thread link below. In particular see #3 where frankc has a story on this particular part.
https://www.jaguarforums.com/forum/x...cation-214529/
 
The Following User Says Thank You to DavidYau For This Useful Post:
macs99 (03-14-2019)
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Jaguar2986
XJS ( X27 )
3
03-09-2017 02:47 PM
his196
MKI / MKII S type 240 340 & Daimler
3
09-25-2014 02:52 PM
calvindoesntknow
XJS ( X27 )
0
04-26-2013 05:51 PM
MLRocafella85
XJ XJ6 / XJR6 ( X300 )
3
06-18-2011 02:19 PM
WillieE
S-Type / S type R Supercharged V8 ( X200 )
3
05-17-2011 11:14 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Ignition problem


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: