Why does it take so long to Start-up? - Page 3 - Jaguar Forums - Jaguar Enthusiasts Forum

Notices
XK8 / XKR ( X100 ) 1996 - 2006

Why does it take so long to Start-up?

 
  #41  
Old 02-09-2018, 11:41 AM
mhminnich's Avatar
Senior Member
Join Date: Oct 2014
Location: Arlington, Texas
Posts: 309
Thanked 84 Times in 73 Posts
Default

Glad you got it worked out, but geez....

Do we have a thread started yet for ''Priceless bits to nab in the wrecking yard when am x100 arrives?!
 
  #42  
Old 03-12-2019, 10:19 AM
Member
Join Date: Feb 2019
Location: Florida Panhandle
Posts: 49
Thanked 2 Times in 2 Posts
Default

Originally Posted by bcprice36 View Post
.Problem solved: Smart Junction Fuse/Relay Box in the Boot....simple fix!! Replace it!

Billy Clyde in Houston
Can you elaborate? I do not see a Smart Junction Fuse in the fuse box chart.

Thanks
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
stmcknig
F-Type ( X152 )
17
05-16-2017 09:43 PM
pbuck
XK8 / XKR ( X100 )
16
04-14-2017 03:21 PM
5tevie
XJ XJ6 / XJR6 ( X300 )
16
06-04-2012 05:52 AM
Jayt2
Off Topic
7
03-11-2012 06:54 AM
quaker13
XK / XKR ( X150 )
2
01-05-2012 10:57 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Why does it take so long to Start-up?


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: