XJ6 & XJ12 Series I, II & III 1968-1992

lady not starting

 
  #1  
Old 10-08-2007, 02:50 PM
Thread Starter
Join Date: May 2007
Posts: 29
Likes: 0
Received 0 Likes on 0 Posts
Default lady not starting

Hi guys, got a problem .....
The car doesn'twant to start (just cranks). When it was running two days agoit ran smooth neither shaking nor backfiring. It just stopped running suddenly like it ran on the quarters ..lol (the machines for kids in front of the supermarkets).
I've changed the coil, battery,spark plugs, gas filter, rotor, distributor cap, spark plug wires, even some of the relays (fuel pump relay, cold start relay and diode unit), fuel pressure regulator,and ignition amplifier.
When the car sits for several hours to cool off it wants to start back on, but the moment I turn it off that’s it.

Please help......
Thank you.
doca
 
  #2  
Old 10-08-2007, 04:23 PM
Jose's Avatar
Veteran Member
Join Date: Mar 2007
Location: Florida
Posts: 5,822
Received 1,338 Likes on 1,088 Posts
Default RE: lady not starting

can youtell methe lady'syear of birth, breed,and model?

Jose
 
  #3  
Old 10-08-2007, 07:14 PM
Thread Starter
Join Date: May 2007
Posts: 29
Likes: 0
Received 0 Likes on 0 Posts
Default RE: lady not starting

1986 XJ6 little over 100k miles
 
  #4  
Old 10-08-2007, 08:43 PM
Jose's Avatar
Veteran Member
Join Date: Mar 2007
Location: Florida
Posts: 5,822
Received 1,338 Likes on 1,088 Posts
Default RE: lady not starting

ok:

1) did you de-pressurize the fuel system when you replaced the Fuel Pressure Regulator and the Fuel Filter ?? (hint: you are supposed to, that's why everyone should have aService Manual for these cars).

2) if you did not de-pressurize, you may have tripped the Fuel Cutoff Inertia Switch which shuts off the Fuel Pump during a serious crash or rollover, or when opening up the pressurized fuel system to atmosphere, like you did. It may have been half-tripped, and eventually it tripped completely.

To find it: go to the passenger side, under the right, end-corner of the dash, and just above the kick-panel, (theupholstery panel on the side of the right leg when your sitting in the passenger's seat);

You will see a square, black, semi-gloss, plastic cover/finisher.Pull it off, it has a spring-clip which keeps it over the Inertia Switch. Once you pull it, you will see a black switchbox with a grey plug and wires at the bottom, anda Reset Button on top.

Press the Reset Button down medium-hard, if you hear a 'click', the switch was tripped. If no click, and the reset button "springs" loosely when you touch it, the switch is fine. Time to look elsewhere.

Let me know.
Jose



[IMG]local://upfiles/1235/6B6A465037C74108A5EA9A28492AD8E4.jpg[/IMG]
 
  #5  
Old 10-09-2007, 02:19 AM
Join Date: Aug 2007
Posts: 65
Likes: 0
Received 1 Like on 1 Post
Default RE: lady not starting

easiest way to check is buy a spark tester/injector tester. The spark plug lightis very simple, itjust plugs in between the wire/rotor or plug/wire and has lights in it and shoudl light while cranking.The Injector checker is also simple. Itspretty much a light bulb thatis able to plug into the injector wires(after u take it off the injector) and should light upif it has a pusle. I recommend these tools for ANYONE who doeswork to their own cars. Its a life saver!If the spark checker lights, and the injectors light. check fuel pressure. If u got fuel pressure, thencheck timing. Beyond that i couldnt tell ya. Hope u find the problem!
 
  #6  
Old 10-09-2007, 01:01 PM
Thread Starter
Join Date: May 2007
Posts: 29
Likes: 0
Received 0 Likes on 0 Posts
Default RE: lady not starting

Hi Jose,
The switch clicked, the car started and ran for10 seconds and then it shut off again. When it startedthe enginedidn't backfire at all.

thank you

1badjag I'm getting spark I already checked that,
the fuel pressure i got....probably a lot.

a few days ago I had one of the hoses from the fuel line leak. One of the small hosesconnectedto the injector.
 
  #7  
Old 10-09-2007, 01:50 PM
Jose's Avatar
Veteran Member
Join Date: Mar 2007
Location: Florida
Posts: 5,822
Received 1,338 Likes on 1,088 Posts
Default RE: lady not starting

ok, so the Inertia Switch was tripped?Did you check to see if it tripped again after it started and shut down? Do you see any fuel leaking anywhere?

Check under the right Front fender (wing), passenger side, where you will see the Charcoal Canister, (a black plastic round "tank", locatedbelow the outer headlamp bucket).

thereare rubber hoses connecting to and from the Charcoal Canister to the engine, andone hose comes from the tanks, from below the car up;You will see a small, black plastic Check Valve, connected on both sidesto that hose,the side coming from the tanks to the check valve, is a big hose; thehose after the check valveis a small hose; Disconnect/pull the bigger hose from the check valve, (the hose on the left). Try to start the car again.
 
  #8  
Old 10-10-2007, 02:30 AM
Thread Starter
Join Date: May 2007
Posts: 29
Likes: 0
Received 0 Likes on 0 Posts
Default RE: lady not starting

ORIGINAL: Jose

.... Do you see any fuel leaking anywhere?

Check under the right Front fender (wing), passenger side, where you will see the Charcoal Canister, (a black plastic round "tank", locatedbelow the outer headlamp bucket).

thereare rubber hoses connecting to and from the Charcoal Canister to the engine, andone hose comes from the tanks, from below the car up;You will see a small, black plastic Check Valve, connected on both sidesto that hose,the side coming from the tanks to the check valve, is a big hose; thehose after the check valveis a small hose; Disconnect/pull the bigger hose from the check valve, (the hose on the left). Try to start the car again.
There is no more leakage,...I've tried unpluging the hoses and nothing....

 
  #9  
Old 10-10-2007, 01:27 PM
Jose's Avatar
Veteran Member
Join Date: Mar 2007
Location: Florida
Posts: 5,822
Received 1,338 Likes on 1,088 Posts
Default RE: lady not starting

the fuel pump circuit needs to be checked next.

click on the following link, and print it for reference, follow the steps to check the 3 components:

http://www.jag-lovers.org/xjlovers/x...lpumpcheck.htm

as you do this, you need to continue checking the Inertia Switch for tripping. It might continue to tripp until a succesful run of the engine, (without it shutting off). Also print the picture below to learn where each component is.

Jose

[IMG]local://upfiles/1235/DBD0E5356D6B470B8A6173E2F7FA4821.jpg[/IMG]
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
99xk8guy
XK8 / XKR ( X100 )
21
06-28-2019 06:32 PM
JarodL
F-Type ( X152 )
53
04-23-2019 09:04 PM
motorhead69
XJ XJ8 / XJR ( X308 )
13
09-09-2015 10:04 AM
Bones
XJ6 & XJ12 Series I, II & III
17
09-08-2015 08:34 PM
philwarner
XJ XJ6 / XJ8 / XJR ( X350 & X358 )
4
09-02-2015 11:45 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: lady not starting


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: