Ctek MXS5.0 - RESOLVED - Jaguar Forums - Jaguar Enthusiasts Forum

Notices
XK / XKR ( X150 ) 2006 - 2014

Ctek MXS5.0 - RESOLVED

Reply

 
 
 
  #1  
Old 01-08-2018, 06:16 AM
peterv8's Avatar
Senior Member
Thread Starter
Join Date: Aug 2017
Location: Södra Sandby, Sweden
Posts: 273
Thanked 36 Times in 33 Posts
Default Ctek MXS5.0 - RESOLVED

Bought a Ctek recently and it's on the car but I have a low buzzing sound from it when it's fully charged? I didn't here anything from my previous charger so is this normal for a Ctek?
 

Last edited by GGG; 01-20-2018 at 05:19 AM. Reason: Add "RESOLVED" to thread title
Reply With Quote
  #2  
Old 01-08-2018, 04:23 PM
Veteran Member
Join Date: Feb 2011
Location: Victoria, Canada
Posts: 1,258
Thanked 503 Times in 374 Posts
Default

The buzzing noise on a CTEK unit means that the connectors are not fully seated ( I am referring to the orange/black connectors). Disconnect them and reconnect. I have had one of these units whose connectors did this quite often. It is not related in any way to the state of charge of the battery.
 
Reply With Quote
The Following User Says Thank You to sov211 For This Useful Post:
dcmackintosh (01-10-2018)
  #3  
Old 01-10-2018, 02:33 PM
peterv8's Avatar
Senior Member
Thread Starter
Join Date: Aug 2017
Location: Södra Sandby, Sweden
Posts: 273
Thanked 36 Times in 33 Posts
Default

Originally Posted by sov211 View Post
The buzzing noise on a CTEK unit means that the connectors are not fully seated ( I am referring to the orange/black connectors). Disconnect them and reconnect. I have had one of these units whose connectors did this quite often. It is not related in any way to the state of charge of the battery.
New cable, still the same buzzing!?
Have sent an email to Ctek about it.
 

Last edited by GGG; 01-15-2018 at 02:56 AM.
Reply With Quote
  #4  
Old 01-14-2018, 06:19 AM
mij86's Avatar
Senior Member
Join Date: Jun 2017
Location: Derbyshire, UK
Posts: 455
Thanked 8 Times in 7 Posts
Default

Mines now been on for 24 hours and I can confirm it is silent.
 
Reply With Quote
  #5  
Old 01-14-2018, 09:59 PM
peterv8's Avatar
Senior Member
Thread Starter
Join Date: Aug 2017
Location: Södra Sandby, Sweden
Posts: 273
Thanked 36 Times in 33 Posts
Default

Sent Ctek a message a few days ago but no answer yet, will call the store and hear what they say.
 
Reply With Quote
  #6  
Old 01-15-2018, 08:40 AM
Senior Member
Join Date: Mar 2012
Location: Fort Worth
Posts: 830
Thanked 299 Times in 215 Posts
Default

I don't know about your specific noise, but it is concerning as mine don't seem to make any noise at all. I've got a few classic cars and been through a few different brands of battery maintainers. Early on, I had Sears Diehard units, the old technology ones that weighed as much as a brick. In 2008, I brought home a couple more cars and bought new Sears Diehard units that looked exactly like the old one but were light as a feather, new technology I guess. Anyway, a few days after plugging in I happened out to the garage when it was very quiet and I heard a battery boiling. The new Sears unit wasn't shutting off when the battery was "full". Luckily I caught it before any serious damage was done. I took the defective unit back to Sears and exchanged it. The very next day I went out to check on them again and I heard the "other" new Sears unit had started "buzzing" and I assumed that to be a sign that it was about to fail too. That was the last straw. I took both of them back to Sears for a refund.

I replaced them with the more expensive "Battery Tender" brand units. Both of those have since failed, but at least the Battery Tenders failed in the "off" position instead of failing full "on" like the Sears. I've since replaced with even more expensive CTEK units. I have four of them going although I haven't had them but a few months so I can't testify to their longevity. But I don't think I would use that one until CTEK responded. Good luck.
 
Reply With Quote
  #7  
Old 01-15-2018, 11:19 AM
Stuart S's Avatar
Veteran Member
Join Date: Aug 2010
Location: Atlanta suburbs
Posts: 4,231
Thanked 1,756 Times in 1,121 Posts
Default

Originally Posted by pdupler View Post
... I replaced them with the more expensive "Battery Tender" brand units. Both of those have since failed, but at least the Battery Tenders failed in the "off" position instead of failing full "on" like the Sears. I've since replaced with even more expensive CTEK units. ...
Why am I not surprised? I bought my last Battery Tender in 2010 based on all the positive Amazon reviews and price. It was marketed by Deltran Corporation of Florida and touted as designed in the USA (although it was made in China). It had a plastic case and overheated without any warning and melted the plastic case. Fortunately, it didn't cause my house to burn down. Worst customer service ever. I'll never buy another Battery Tender by Deltran brand product again.

+1 for CTEK. I've never had a problem with mine and it works as advertised.

See my Post #7 in this thread: https://www.jaguarforums.com/forum/x...at-buy-155990/

BUY THE CTEK, GET THE KOENIGSEGG FOR FREE!
 
Reply With Quote
  #8  
Old 01-18-2018, 09:53 PM
peterv8's Avatar
Senior Member
Thread Starter
Join Date: Aug 2017
Location: Södra Sandby, Sweden
Posts: 273
Thanked 36 Times in 33 Posts
Default

Finally got a response from Ctek.
They said it's normal they make a low buzzing sound at different stages of charging. I noticed mine was silent in the morning but later in the day I could hear it again.
 
Reply With Quote
The Following User Says Thank You to peterv8 For This Useful Post:
GGG (01-20-2018)
  #9  
Old 01-19-2018, 02:22 AM
mij86's Avatar
Senior Member
Join Date: Jun 2017
Location: Derbyshire, UK
Posts: 455
Thanked 8 Times in 7 Posts
Default

How old is your battery ?
wondering if its taking a lot of out of the Ctek?
 
Reply With Quote
  #10  
Old 01-19-2018, 02:24 AM
peterv8's Avatar
Senior Member
Thread Starter
Join Date: Aug 2017
Location: Södra Sandby, Sweden
Posts: 273
Thanked 36 Times in 33 Posts
Default

Originally Posted by mij86 View Post
How old is your battery ?
wondering if its taking a lot of out of the Ctek?
Bought a new AGM battery end of summer.
 
Reply With Quote
  #11  
Old 01-19-2018, 02:34 AM
mij86's Avatar
Senior Member
Join Date: Jun 2017
Location: Derbyshire, UK
Posts: 455
Thanked 8 Times in 7 Posts
Default

Well that's that theory out the window.. just been out in the garage and listed to mine and it's completely silent temperature is currently -2.
Does yours fluctuate with the temperatures over there?
 
Reply With Quote
  #12  
Old 01-20-2018, 02:34 AM
peterv8's Avatar
Senior Member
Thread Starter
Join Date: Aug 2017
Location: Södra Sandby, Sweden
Posts: 273
Thanked 36 Times in 33 Posts
Default

Originally Posted by mij86 View Post
Well that's that theory out the window.. just been out in the garage and listed to mine and it's completely silent temperature is currently -2.
Does yours fluctuate with the temperatures over there?
I don't have a multimeter on the car but I can hear it now and then. I'm happy with the answer from Ctek custom support. If they say they do it I trust them, I don't see why they would lie about it.:-)
 
Reply With Quote
The Following User Says Thank You to peterv8 For This Useful Post:
GGG (01-20-2018)
  #13  
Old 01-20-2018, 03:59 AM
mij86's Avatar
Senior Member
Join Date: Jun 2017
Location: Derbyshire, UK
Posts: 455
Thanked 8 Times in 7 Posts
Default

I guess with it being an electronic device certain components may generate a buzz, I remember the old battery chargers with the transformers in did this, the old wire coils vibrating!
 
Reply With Quote
  #14  
Old 01-20-2018, 05:18 AM
GGG's Avatar
GGG
GGG is online now
Join Date: Dec 2011
Location: Durham, UK
Posts: 105,695
Thanked 9,265 Times in 7,736 Posts
Default

Originally Posted by peterv8 View Post
Finally got a response from Ctek.
They said it's normal they make a low buzzing sound at different stages of charging. .....
Originally Posted by peterv8 View Post
..... I'm happy with the answer from Ctek custom support. If they say they do it I trust them, I don't see why they would lie about it.
I agree.

CTEK is a quality product many of us use and it makes no sense that they would advise a buyer that this buzzing is normal if there was any risk of malfunction that could lead to overheating or worse.

I've added "RESOLVED" to your thread title. This isn't to close the debate but simply to indicate your question has been answered by CTEK.

Graham
 
Reply With Quote
The Following User Says Thank You to GGG For This Useful Post:
peterv8 (01-20-2018)
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
richzak
XK / XKR ( X150 )
326
01-19-2018 07:03 AM
bocatrip
XK / XKR ( X150 )
23
03-28-2014 07:03 PM
chazaroo
XK / XKR ( X150 )
2
02-10-2014 07:39 AM
GGG
General Tech Help
7
11-21-2013 02:36 AM
RCG
XJ XJ6 / XJ8 / XJR ( X350 & X358 )
2
10-06-2013 08:13 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: