Instrument Cluster needs new bulbs? - Jaguar Forums - Jaguar Enthusiasts Forum

Notices
XJS ( X27 ) 1975 - 1996 3.6 4.0 5.3 6.0

Instrument Cluster needs new bulbs?

 
  #1  
Old 03-03-2019, 11:34 AM
Member
Thread Starter
Join Date: Jun 2015
Location: Oklahoma City
Posts: 32
Thanked 3 Times in 3 Posts
Default Instrument Cluster needs new bulbs?

I need to pull my instrument cluster due to a rattle somewhere and thought while I'm at it clean all the contacts and replace all my bulbs. I'm not crazy about the light that LED's produce so just want new, brighter bulbs. Is there a replacement light bulb kit available that has all the bulbs?

Thanks
 
  #2  
Old 03-03-2019, 11:45 AM
Vee
Vee is offline
Veteran Member
Join Date: May 2010
Location: Arlington, VA
Posts: 2,629
Thanked 580 Times in 484 Posts
Default

Would be helpful to tell us what model year you have....
 
  #3  
Old 03-03-2019, 12:02 PM
Member
Thread Starter
Join Date: Jun 2015
Location: Oklahoma City
Posts: 32
Thanked 3 Times in 3 Posts
Default

Oh sorry VEE I guess it would... 1990 XJS V12
 
  #4  
Old 03-03-2019, 12:12 PM
Veteran Member
Join Date: Jan 2012
Location: France
Posts: 8,805
Thanked 4,331 Times in 2,769 Posts
Default

If you would like normal instrument illumination bulbs, but brighter, then I suggest using 5watt pushfits (OEM they are 2 watt and just not bright enough, even when new). I have been using them for years and they are quite bright enough. They are a direct fit into the black bulb holders and look the same as the OEM 2 watts.
Amazon Amazon
Also, there are small green dome-shaped filters over the bulb inside the cluster, it is a very good plan to remove these as they go dark, which you do by unscrewing the white part of the cluster from the black part. and then removing the filters.
The warning light bulbs are T5s:
https://www.ebay.fr/i/283328169501?chn=ps&dispItem=1
There are LED T5s made, but you must use an old-fashioned filament bulb in the charging light warning socket even if you change the others to LEDs. But beware that LED T5s can be hard to fit into the tiny bulb holders, and they are polarity sensitive, and will not work if the wrong way round.
 

Last edited by Greg in France; 03-03-2019 at 01:29 PM.
  #5  
Old 03-03-2019, 12:36 PM
Member
Thread Starter
Join Date: Jun 2015
Location: Oklahoma City
Posts: 32
Thanked 3 Times in 3 Posts
Default

Thanks Greg!!!!!
 
  #6  
Old 03-03-2019, 06:08 PM
Member
Thread Starter
Join Date: Jun 2015
Location: Oklahoma City
Posts: 32
Thanked 3 Times in 3 Posts
Default

So I think I got the wrong bulbs... I ordered the 286 12V 1.2 watt ampoule bulbs but stoped in Autozone to pick up the 5 for the cluster... The guy gave me Sylvania 2825 12v 5 watt bulbs. They look the same but put gauge cluster back in and everything works except those!!!! Did I get the wrong bulbs???
 
  #7  
Old 03-04-2019, 01:13 AM
Veteran Member
Join Date: Jan 2012
Location: France
Posts: 8,805
Thanked 4,331 Times in 2,769 Posts
Default

Originally Posted by Lgreen View Post
So I think I got the wrong bulbs... I ordered the 286 12V 1.2 watt ampoule bulbs but stoped in Autozone to pick up the 5 for the cluster... The guy gave me Sylvania 2825 12v 5 watt bulbs. They look the same but put gauge cluster back in and everything works except those!!!! Did I get the wrong bulbs???
More likely the 12 v feed via the multiplug is not making contact where it is plugged into the cluster. Possible fuse issue too, do the other lights come on, eg heater controls, gearshift illumination? If they do, then nothing but to pull the cluster and check the bulb holders with a 12 v source and diagnose from there.
 
  #8  
Old 03-04-2019, 09:22 AM
Member
Thread Starter
Join Date: Jun 2015
Location: Oklahoma City
Posts: 32
Thanked 3 Times in 3 Posts
Default

OK so I'm an Idiot... I had been messing with the dimmer knob and had it turned all the way down!!! Everything works and is brighter now. Looks much better than before. The little bulbs should come in the mail this week... glad I don't have to take the cluster out to change those.

Thanks
 
The Following User Says Thank You to Lgreen For This Useful Post:
Greg in France (03-04-2019)
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
car5car
S-Type / S type R Supercharged V8 ( X200 )
7
05-05-2017 09:31 AM
Tracy Weiland
XK8 / XKR ( X100 )
4
08-28-2016 11:34 PM
Spurlee
XK8 / XKR ( X100 )
15
10-03-2014 08:33 PM
05XK8
XK8 / XKR ( X100 )
14
07-22-2014 05:23 AM
cadrad
XJ XJ8 / XJR ( X308 )
0
11-01-2009 06:39 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Instrument Cluster needs new bulbs?


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: