XF and XFR ( X250 ) 2007 - 2015

playing audio on xf 2011

 
  #1  
Old 04-02-2018, 05:02 AM
Junior Member
Thread Starter
Join Date: Apr 2018
Location: Manchester
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Default playing audio on xf 2011

Hi I have tried everything to be able to use the car interface to control my iphone/ipod music. The only way i can play music is through the aux cable with ipod. i cant play anything from my iphone. Car screen just says paused. I have tried using the car screen but nothing works. Can anyone give me a step by step way of being able to control music on car screen please. XF 2011 premium luxury. Amazing car but frustrating media stuff
 
  #2  
Old 04-02-2018, 06:24 AM
Join Date: Jan 2011
Location: Sydney, Australia
Posts: 8,339
Received 3,743 Likes on 2,205 Posts
Default

You have the iPod/USB interface in the armrest?

Buy a Bovee Tune2Air WMA1000. Plug it in to the iPod cable.

Connect your phone to the WMA1000, the car will see it as an iPod.

Have at least one mp3 on your phone for the car to "see"

Then you can stream audio from Spotify or Youtube or whatever.

 
  #3  
Old 04-02-2018, 08:17 PM
Veteran Member
Join Date: May 2012
Location: Boston
Posts: 1,304
Received 196 Likes on 185 Posts
Default

Agreed. That's exactly the setup I've had for several years and it's great. Center console and steering wheel controls to skip songs. And tune names appear on the center screen.
 
  #4  
Old 04-11-2018, 09:09 PM
Member
Join Date: Dec 2015
Location: Asheville NC
Posts: 83
Received 4 Likes on 3 Posts
Default

Great video Cambo, I'm trying to get this setup for my 11 Xf also. Got the Bovee 1000, attached it via the iPod cable to the ipod socket. Could pair without trouble switching on my phone's bluetooth. Showed it was connected on the bluetooth area in the iphone bluetooth settings.

Went into the audio section on the nav screen, and pressed ipod. Saw the song name listed, but strangely the seek back and seek forward buttons were grayed out. Additionally, could not switch songs on the steering wheel. I'm trying to play songs on spotify. Strangely when I press play on the iphone, the song plays for about half a second and then stops. This happened every time I tried.

I thought perhaps my internet cellular wasn't good enough, but I changed to AUX port, and it worked fine. It doesn't seem to be an internet problem.. What I tried doing was re-starting the phone, and re-connecting the ipod cable to the ipod socket, and re-connecting the Bovee - making sure all clicked. Doesn't work though.

You have any ideas Cambo on what could be causing this? Or BritCars - did you experience this at all..? Being able to see the track on screen and seek between on the steering wheel is great and that's why I got the Bovee but just trying to get it to work!

I could provide any additional information regarding this - thanks for any help or suggestions you might have.
 
  #5  
Old 04-11-2018, 09:13 PM
Join Date: Jan 2011
Location: Sydney, Australia
Posts: 8,339
Received 3,743 Likes on 2,205 Posts
Default

Have you got at least one song on the phone? That's the trick to getting streaming working.
 
  #6  
Old 04-11-2018, 10:37 PM
Member
Join Date: Dec 2015
Location: Asheville NC
Posts: 83
Received 4 Likes on 3 Posts
Default

Yes! I tried to play any song from a Spotify playlist which has about 100 tracks. My phone is connected to a cellular 4G network, and can play the songs on the go. Over the last few years, before I saw your video, I would just connect it via Auxilary cable and it worked well. It plays consistently while connected via AUX cable to the car..
 
  #7  
Old 04-11-2018, 10:44 PM
Join Date: Jan 2011
Location: Sydney, Australia
Posts: 8,339
Received 3,743 Likes on 2,205 Posts
Default

Try putting some songs actually on the phone, separate to Spotify, using iTunes or whatever.
 
The following users liked this post:
bluejaag (04-12-2018)
  #8  
Old 04-12-2018, 07:30 PM
Veteran Member
Join Date: May 2012
Location: Boston
Posts: 1,304
Received 196 Likes on 185 Posts
Default

Yes - when it connects to the iPhone it tried to 'dock' it like an iPod. So if you have a few mp3 songs locally actually on the phone (eg sync a few on iTunes) then it will dock ok and you should then be able to stream via Spotify. Note that VBR (variable bit rate) and too high bit rates may cause issues so keep it at say 128kbps

Also on mine if I play from the phone it won't play if the car control is paused. So you need to go into that iPod setting on the center console and press the play triangle. After that you can select what to play (eg Spotify) on the phone. Then it should stream and all controls should work

Once you have it going it's not as complex as this all makes it sound! It should just connect automatically and play whatever you tell it to after that!
 
The following users liked this post:
bluejaag (04-12-2018)
  #9  
Old 04-12-2018, 08:49 PM
Member
Join Date: Dec 2015
Location: Asheville NC
Posts: 83
Received 4 Likes on 3 Posts
Default

Thanks for helpful comments Cambo and BritCars! I see, based on your comments, it seems to treat is more of a local device/hard disk storage type of thing, and may not recognize a Spotify playlist thru the App as a collection of seek-able tracks.

What I've just found out is that I downloaded a spotify playlist [for use while offline], and when I pressed a song, lo and behold the seek forward/back buttons illuminated, and I was able to use the steering wheel to change the track etc. Success!

While I don't mind downloading everything to the phone itself, I like exploring Spotify's new categories and it's a bit of a hassle to download everything!! Ideally, and what I really hope, is that if I press a downloaded song, it docks all well, and I can go into another playlist, with new songs I haven't heard - and play them!

Im going to try that, as well as try and see if I can play thru YouTube, in the next day or 2! Although, with a song on YouTube not being stored locally on the iPhone, I'll be curious to see if that works for me..
 

Last edited by bluejaag; 04-12-2018 at 08:53 PM.
  #10  
Old 04-12-2018, 09:39 PM
Join Date: Jan 2011
Location: Sydney, Australia
Posts: 8,339
Received 3,743 Likes on 2,205 Posts
Default

The car only looks for an iPod, so there needs to be "tracks on an iPod" that means your Spotify downloads maybe/probably don't count towards that.

So long as there is one track on the phone and the car sees an "iPod with one track on it" then it pairs up properly and you can then use any audio source via the phone; youtube, spotify, whatever. But first it needs to see an iPod/iPhone with a track on it.

You do not need to download anything else to the phone, just manually copy one mp3 to the phone, everything after that can be streamed.
 
  #11  
Old 04-15-2018, 03:56 PM
Member
Join Date: Dec 2015
Location: Asheville NC
Posts: 83
Received 4 Likes on 3 Posts
Default

Put an iTunes song on the phone - played it - and was able to seek thru Spotify songs and stream. Great!! Thanks again.
 
  #12  
Old 04-30-2018, 02:47 PM
Junior Member
Join Date: Apr 2018
Posts: 5
Likes: 0
Received 0 Likes on 0 Posts
Default

Anyone Ireland/UK, where did you buy this device? I can only find it on American sites?
 
  #13  
Old 02-06-2019, 12:37 PM
Junior Member
Join Date: Aug 2018
Location: Poole, Dorset
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Default

Hey, I have an interesting one. I have connected my iPod touch 4th Gen and I put Spotify on there and like some of you guys have said after putting an actual track on via iTunes, I could stream Spotify.

The problem I have is the track listing is actually one behind the one that is playing, so when I skip track its showing me the name of the track just played rather than the current one. Also the name doesnt update when it moves onto the next track by itself i.e. after the previous track has finished.

Any Ideas?
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Andy6878
XF and XFR ( X250 )
2
04-01-2018 06:12 PM
Loughclan
XJ ( X351 )
2
03-27-2018 12:15 PM
jasonfig
General Tech Help
1
03-07-2018 06:51 PM
jasonfig
XF and XFR ( X250 )
1
03-07-2018 06:51 PM
vacolorito
XK / XKR ( X150 )
43
08-22-2016 12:02 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: playing audio on xf 2011


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: